Hexagora Forum
Hexagora Forum
Home | Profile | Active Topics | Members | Search | FAQ
Username:
Password:
Save Password
Forgot your Password?

 All Forums
 Other hexagora products
 Programs (Programmi)
 issue - unexpected behavors of ctlUniFormCaption
 New Topic  Reply to Topic
 Printer Friendly
Author Previous Topic Topic Next Topic  

alfredoc
Novice

France
7 Posts

Posted - 04 Dec 2014 :  01:27:01  Show Profile  Visit alfredoc's Homepage  Reply with Quote
Hi,

I have been unable to understand why I encounter an issue with the ctlUniFormCaption control.

For some unexpected reason, I have one use-case where the value of ctlUniFormCaption.Caption is altered.

Say I set this caption to "myString", what is displayed: "myString - [ myString ]".

The case : have an MDIForm which opens and closes sub-forms. Any sub form caption overides MDIForm caption when the subform is display in full screen inside the MDIForm. If minimized or reduced, the sub form has its own title and the MDIForm has its own title.

I created a mock project and have (of course) been unable to reproduce the issue. But inside our application is something that makes it fail. And I see no code that would manipulate the string i sch a way and add such a formatting.

I hae been wondering about a potential explanation regarding a succession of events but I cannot see yet why the issue occurs.

Fact is that I added a Watch on the MDIform caption and it always comes to these cases :
- if I set up the MDIForm caption before calling SubForm.show, MDIForm.ctlUniFormCaption.Caption get badly altered as soon I call subForm.Show.
- if I set up the MDIForm caption after calling SubForm.show, MDIForm.ctlUniFormCaption.Caption get badly altered when I set its caption value as in"ctlUniFormCaption.Caption = "test" ==> ctlUniFormCaption.Caption shows "test - [test]".

Any idea why please?

Edited by - alfredoc on 04 Dec 2014 01:31:16

alfredoc
Novice

France
7 Posts

Posted - 04 Dec 2014 :  02:10:50  Show Profile  Visit alfredoc's Homepage  Reply with Quote
:-)

I regret to admit that I focused hardly on uniformcaption and missed something.
I re-read how MDI Form works and found why I see those [] (http://msdn.microsoft.com/en-us/library/aa733529(v=vs.60).aspx)

I DO have an issue in the MDIform caption when using ctlUniformCaption.
Step by step:
1) open MDI Form -> MDI form caption displayed : "NAME"
2) execute a menu of the MDI Form to open a Sub Form. The sub form should have the caption: "SubForm".
MDI form caption should displayed : "NAME [Subform]".
What MDI form caption displays is : "NAME - [Subform] - [Subform] - [ Subform ]" "the 3 occuenrece is truncated.

As you can understand, I see the subform caption repeated at least twice.

Any idea why?

Go to Top of Page

alfredoc
Novice

France
7 Posts

Posted - 04 Dec 2014 :  04:44:26  Show Profile  Visit alfredoc's Homepage  Reply with Quote
And to be precise, it happens when running Windows Server 2008R2
Go to Top of Page

s.dav
Site Admin

Italy
3360 Posts

Posted - 04 Dec 2014 :  04:59:25  Show Profile  Visit s.dav's Homepage  Reply with Quote
alfredoc, this appears to be quite strange to me; never seen an issue like yours.
If you are able to reproduce the problem, please send me a sample and I'll investigate.

Regards, Davide
Go to Top of Page
  Previous Topic Topic Next Topic  
 New Topic  Reply to Topic
 Printer Friendly
Jump To:
Hexagora Forum © s.dav Go To Top Of Page
Snitz Forums 2000