Hexagora Forum
Hexagora Forum
Home | Profile | Register | Active Topics | Members | Search | FAQ
Username:
Password:
Save Password
Forgot your Password?

 All Forums
 Dynamic HTML Editor
 Dynamic HTML Editor
 email form, using dhtml editor 5.5.37
 New Topic  Reply to Topic
 Printer Friendly
Author Previous Topic Topic Next Topic  

jimmystyler
Novice

Italy
6 Posts

Posted - 08 Feb 2011 :  13:20:52  Show Profile  Visit jimmystyler's Homepage  Reply with Quote
hi everybody!
i'm a newbie, and i'm surly missing something using the form tool to make a simple email form.

i know that i can't try the form directly in local, and that i need first to upload all the work on the server, but the point is that i don't understand an error that firefox shows up. this is what i did:

- created a form
- created the fields (button, mail_address_box, text_box)
- set up exporting page in .php, form processing and validation

after i fill all the required fields, this is the error that firefox shows

"Impossibile trovare il file /D:/Programmi/DHTML/Icas94/SITO/<?php echo basename(__FILE__);?>."

/*it's in italian, but it says that 'it's impossible to find the file' specified in the path...*/

what am i missing? if i upload the whole work on the server it will work? (unfortunately i can't access the server space at the moment because i'm waiting for the login passwords)

thanks a lot for reading and for helping!

candid
Expert

South Africa
53 Posts

Posted - 09 Feb 2011 :  09:06:55  Show Profile  Visit candid's Homepage  Reply with Quote
Hi Jimmy,

I'll guess, and say the browser is trying to find the php script file for the form, after you hit submit, and somehow can't find it. I think you will have to export all your files first, and do a test when all the files are on the server as you mention. Maybe someone else has a better idea about the error message you get.

*By the way - welcome to the forum

Cheers - George
Go to Top of Page

s.dav
Site Admin

Italy
3360 Posts

Posted - 09 Feb 2011 :  11:28:39  Show Profile  Visit s.dav's Homepage  Reply with Quote
>on the server it will work?

Yes, it should work but you need to use a Hosting provider that support PHP ;-)

Regards, Davide
Go to Top of Page

jimmystyler
Novice

Italy
6 Posts

Posted - 10 Feb 2011 :  11:05:16  Show Profile  Visit jimmystyler's Homepage  Reply with Quote
Thank you all so much for your replies!
i'll let you know in a few days if all works fine

(and by the way DHTML editor rocks!)
Go to Top of Page

jimmystyler
Novice

Italy
6 Posts

Posted - 03 Mar 2011 :  12:44:17  Show Profile  Visit jimmystyler's Homepage  Reply with Quote
All right at the end!
the mail form works perfectly, but i had to export the page in .asp because the server doesn't support php.

thanks again for the support and enjoy it: www.icas94.it
bye bye
Go to Top of Page

jimmystyler
Novice

Italy
6 Posts

Posted - 25 Feb 2015 :  05:39:04  Show Profile  Visit jimmystyler's Homepage  Reply with Quote
Hello again everyone!

Still having problem with the email form (5.9.3 software version) and I can't understand why since in the past it worked perfectly. This is what i've done:

- created a form
- added email field, text field and a submit button
- in the form processing properties I've selected "asp form processing", and filled the mail address field, subject and linked the success and failure pages (both .asp as well)
- in the validation tab I've selected the proper validation regular expressions

The web server can handle asp forms, but the problem is that when i submit the form i get redirected to the failure page. So the asp is clearly working properly, but i can't understand why i get a failure.

this is the website page: http://www.icas94.com/contatti.asp

thanks again for the support!
Go to Top of Page

s.dav
Site Admin

Italy
3360 Posts

Posted - 25 Feb 2015 :  09:55:51  Show Profile  Visit s.dav's Homepage  Reply with Quote
maybe this depends on the version of php installed on the server or on the php global settings

Regards, Davide
Go to Top of Page

jimmystyler
Novice

Italy
6 Posts

Posted - 25 Feb 2015 :  10:06:07  Show Profile  Visit jimmystyler's Homepage  Reply with Quote
thanks for the answer!
The fact is that i'm working with asp and not with php, or am i missing something?
Go to Top of Page

s.dav
Site Admin

Italy
3360 Posts

Posted - 25 Feb 2015 :  23:53:41  Show Profile  Visit s.dav's Homepage  Reply with Quote
Could be the same, something related with your hosting provider and your email server settings

Regards, Davide
Go to Top of Page
  Previous Topic Topic Next Topic  
 New Topic  Reply to Topic
 Printer Friendly
Jump To:
Hexagora Forum © s.dav Go To Top Of Page
Snitz Forums 2000