Hexagora Forum
Hexagora Forum
Home | Profile | Register | Active Topics | Members | Search | FAQ
 All Forums
 Other hexagora products
 Programs (Programmi)
 issue - unexpected behavors of ctlUniFormCaption

Note: You must be registered in order to post a reply.
To register, click here. Registration is FREE!

Screensize:
UserName:
Password:
Format Mode:
Format: BoldItalicizedUnderlineStrikethrough Align LeftCenteredAlign Right Horizontal Rule Insert HyperlinkInsert Email Insert CodeInsert QuoteInsert List
   
Message:

* HTML is OFF
* Forum Code is ON
Smilies
Smile [:)] Big Smile [:D] Cool [8D] Blush [:I]
Tongue [:P] Evil [):] Wink [;)] Clown [:o)]
Black Eye [B)] Eight Ball [8] Frown [:(] Shy [8)]
Shocked [:0] Angry [:(!] Dead [xx(] Sleepy [|)]
Kisses [:X] Approve [^] Disapprove [V] Question [?]

 
   

T O P I C    R E V I E W
alfredoc Posted - 04 Dec 2014 : 01:27:01
Hi,

I have been unable to understand why I encounter an issue with the ctlUniFormCaption control.

For some unexpected reason, I have one use-case where the value of ctlUniFormCaption.Caption is altered.

Say I set this caption to "myString", what is displayed: "myString - [ myString ]".

The case : have an MDIForm which opens and closes sub-forms. Any sub form caption overides MDIForm caption when the subform is display in full screen inside the MDIForm. If minimized or reduced, the sub form has its own title and the MDIForm has its own title.

I created a mock project and have (of course) been unable to reproduce the issue. But inside our application is something that makes it fail. And I see no code that would manipulate the string i sch a way and add such a formatting.

I hae been wondering about a potential explanation regarding a succession of events but I cannot see yet why the issue occurs.

Fact is that I added a Watch on the MDIform caption and it always comes to these cases :
- if I set up the MDIForm caption before calling SubForm.show, MDIForm.ctlUniFormCaption.Caption get badly altered as soon I call subForm.Show.
- if I set up the MDIForm caption after calling SubForm.show, MDIForm.ctlUniFormCaption.Caption get badly altered when I set its caption value as in"ctlUniFormCaption.Caption = "test" ==> ctlUniFormCaption.Caption shows "test - [test]".

Any idea why please?
3   L A T E S T    R E P L I E S    (Newest First)
s.dav Posted - 04 Dec 2014 : 04:59:25
alfredoc, this appears to be quite strange to me; never seen an issue like yours.
If you are able to reproduce the problem, please send me a sample and I'll investigate.
alfredoc Posted - 04 Dec 2014 : 04:44:26
And to be precise, it happens when running Windows Server 2008R2
alfredoc Posted - 04 Dec 2014 : 02:10:50
:-)

I regret to admit that I focused hardly on uniformcaption and missed something.
I re-read how MDI Form works and found why I see those [] (http://msdn.microsoft.com/en-us/library/aa733529(v=vs.60).aspx)

I DO have an issue in the MDIform caption when using ctlUniformCaption.
Step by step:
1) open MDI Form -> MDI form caption displayed : "NAME"
2) execute a menu of the MDI Form to open a Sub Form. The sub form should have the caption: "SubForm".
MDI form caption should displayed : "NAME [Subform]".
What MDI form caption displays is : "NAME - [Subform] - [Subform] - [ Subform ]" "the 3 occuenrece is truncated.

As you can understand, I see the subform caption repeated at least twice.

Any idea why?


Hexagora Forum © s.dav Go To Top Of Page
Snitz Forums 2000