Hexagora Forum
Hexagora Forum
Home | Profile | Register | Active Topics | Members | Search | FAQ
 All Forums
 Other hexagora products
 Programs (Programmi)
 Listview with no Item selected possible?

Note: You must be registered in order to post a reply.
To register, click here. Registration is FREE!

Screensize:
UserName:
Password:
Format Mode:
Format: BoldItalicizedUnderlineStrikethrough Align LeftCenteredAlign Right Horizontal Rule Insert HyperlinkInsert Email Insert CodeInsert QuoteInsert List
   
Message:

* HTML is OFF
* Forum Code is ON
Smilies
Smile [:)] Big Smile [:D] Cool [8D] Blush [:I]
Tongue [:P] Evil [):] Wink [;)] Clown [:o)]
Black Eye [B)] Eight Ball [8] Frown [:(] Shy [8)]
Shocked [:0] Angry [:(!] Dead [xx(] Sleepy [|)]
Kisses [:X] Approve [^] Disapprove [V] Question [?]

 
   

T O P I C    R E V I E W
catweazle Posted - 05 Nov 2014 : 02:32:07
I developped an 'Explorer-like' control, using a treeview and a listview. When I click on a treeview node, its childnodes are listed in the listview.
As the controls standard behaviour, the first ListItem is selected. Is it possible, that no ListItem becomes selected?
I already tried: .SelectAll False
This works when I debug the code, but not if I run the code without breakpoint.

Btw. Same behaviour in frmListView of your Sample Project1, if you add .SelectAll false in the Form_Load Event.
2   L A T E S T    R E P L I E S    (Newest First)
s.dav Posted - 17 Nov 2014 : 00:28:10
Added a new proprerty: "AutoSelectFirstItem"
s.dav Posted - 05 Nov 2014 : 08:26:37
It should work as the standard ListView control. I removed the auto selection for the first item but I need some tests before releasing it because it can cause many problems

Hexagora Forum © s.dav Go To Top Of Page
Snitz Forums 2000