Hexagora Forum
Hexagora Forum
Home | Profile | Register | Active Topics | Members | Search | FAQ
 All Forums
 Other hexagora products
 Programs (Programmi)
 [BUG] Unicode Controls 3.2

Note: You must be registered in order to post a reply.
To register, click here. Registration is FREE!

Screensize:
UserName:
Password:
Format Mode:
Format: BoldItalicizedUnderlineStrikethrough Align LeftCenteredAlign Right Horizontal Rule Insert HyperlinkInsert Email Insert CodeInsert QuoteInsert List
   
Message:

* HTML is OFF
* Forum Code is ON
Smilies
Smile [:)] Big Smile [:D] Cool [8D] Blush [:I]
Tongue [:P] Evil [):] Wink [;)] Clown [:o)]
Black Eye [B)] Eight Ball [8] Frown [:(] Shy [8)]
Shocked [:0] Angry [:(!] Dead [xx(] Sleepy [|)]
Kisses [:X] Approve [^] Disapprove [V] Question [?]

 
   

T O P I C    R E V I E W
nikolaus Posted - 09 Oct 2013 : 19:51:05
Hi Davide,

I attached Hex strings of different languages to a form menu, so to say like you did in your samples. Unfortunately I discovered, that NOT all languages can be written to the captions successfully. For example a Korean string for 'End' I can write to the caption of a menu item as often as I like (e.g. in a loop), but the string will never become written successfully. Interesting, that other asian languages tend to do so too (Chinese, Thai, Japanese), but latin based languages not (English, Portuguese, Italian, German, Swedisch...). And if a string my not become written successfully to a caption, the caption of that specific menu item shows in runtime a string that was previously written to another menu item. As a result I get a menu with two or 4 identical menu captions within a menu of 7 items over all.
I made a screenshot of the code section. If you give me an eMail address, I'll post the screenshot.
Thanks to have a look at it.
Sincerely, Nikolaus
5   L A T E S T    R E P L I E S    (Newest First)
Jan van Londen Posted - 11 Oct 2013 : 12:58:48
I did not mean programme-coding or so, but merely the communication between the two of you.
You can allways send me a personal message via this forum.
nikolaus Posted - 10 Oct 2013 : 19:36:15
Hi Davide, thank you for your reply! I just sent a screenshot of the some lines that cause(?) the problem.
Because the project contains 163 pages and forms, I'm on my way to build a small sample to reproduce the problem. I'll be back soon. Thank you! Nikolaus

Hi Jan, thank you too, for offering help! If you have an eMail address, I'll send you a picture of the relevant code lines.
Sincerely, Nikolaus
Jan van Londen Posted - 10 Oct 2013 : 17:04:15
Hello Davide and Claus,

If there is a "language-problem" maybe I can be of any help. Claus you could send the problem to me (in German) and maybe I can translate.
(Claus, ich hoffe das ich dich Ihnen nicht beleidige.)
s.dav Posted - 10 Oct 2013 : 13:08:11
I understood nothing of your explanation; please send me a mail (check our contact page for the address) with a sample so I can check it
nikolaus Posted - 09 Oct 2013 : 20:01:42
Another thing I discovered that refers the bug posted previously:
In my 7 items containing menu, only one out of the captions (menu items) contain a leading picture (left of the caption). If this menu item fails getting the correct caption, then not only the caption of a previously written caption is shown, the picture is NOT included too. As a result, not any picture is shown in the menu.
If a menu item, that is written later than the one with the picture, and this later item fails and "is deciding to grab" the caption of the item with the picture, then the picture is shown too (!) on this item. As a result I get two (or more) menu items with pictures included, but when I write strings of a latin based language chars (English, Italian, German, Swedish...), everything is okay, each item gets its correct caption and picture (or not) too.

Hexagora Forum © s.dav Go To Top Of Page
Snitz Forums 2000